总部显示已连接,门店服务器启动提示“全局只读”报错
2018-08-27    易林江
1542 0
用于解决,连锁企业,门店连接数据配置正常,但启动门店服务器时,提示“同步全局只读数据发生错误”,但总部显示已连接的问题。
  • 问题说明

    可能的原因:

    1、门店与总部是同一局域网,其他门店是通过花生壳连接,在门店服务器上可以ping通总部IP地址,但是花生壳域名ping不通,按说通过局域网IP地址,进行相互连接是没有问题,但是也还是连接提示“同步全局只读数据失败”,启动门店服务器时,“连锁一致性检查”也通过了,到了“启动加载数据服务”后报的错误。

    2、跟客户之前电脑使用过VPN来访问,而VPN的网络连接还存在。形成了双网络导致的。

    3、访问总部服务器的IP地址或域名,因为印特程序更新后,存在冲突,需更新。

    同类型问题还有:

    门店利用花生壳域名,可以登陆连接总部客户端,但是门店服务器无法连接该花生壳域名连接总部服务器,大概率是因为网络连接问题,可尝试更新IP地址为自动获取的IP和DNS,重启电脑再连接。后续再根据自动获取IP和DNS,设置为手动IP地址和DNS信息。

  • 解决方法

    1、检查下该电脑是否有安装 .net 2.0 SP2 版本,如果没有的话,利用清理工具清除.net程序,再重装.net 2.0 SP2。之后再重新运行服务器程序。

    2、将印特服务器目录下的“EMSNServerCfg.xml”文件里的“总部连接IP地址或域名信息”故意修改成一个错误的IP地址(如:127.0.0.1)保存文件后,再启动门店服务器,之后再重新改回正确的总部IP地址,再重启服务器连接。

    3、最后,可尝试换一台电脑,重新恢复印特数据,再连接总部。走局域网试试看是否可以解决。

该文章对您有用吗?

非常感谢,您的反馈对我们很有价值!

客服电话

4006757966

微信公众号

联系我们

印特3系演示版

申请

印特5系演示版

申请

免费试用

印特软件标准演示版下载申请

请您填写您的一些信息,提交您的申请后,我们会在两个工作日内进行处理,并回复您一封邮件,内附下载链接,请您注意查收。
*
请输入正确的公司名称
*
请输入正确的联络人员
*
请输入正确的联络电话
提交申请
关闭